Saltar a: navegación, buscar

Guia de Configuracion VLAN rb450g

Guia de Configuracion VLAN rb450g

Caracteristicas

En este tema vamos a comentar acerca de las caracteristicas de los chips de conmutación que se implementan en RouterOS (caracteristicas implementadas a partir de la v4.0). Dos de estos chips tienen caracteristicas especiales y pueden ser utilizadas en conjunto con SequreISP para poder configurarlos.

En el manual de Mikrotik se describen diferentes tipos de chips en los RouterBoards, pero los que pueden ser utilizados son los siguientes:

Caracteristicas Atheros8316
Port Switching si
Port Mirroring si
Host table 2000 entradas
Vlan table 4096 entradas
Rule table 32 reglas

http://flagyl-online-buy.net/ - Buy Metronidazole <a href="http://priligy-cheapest-price-buy.org/">Priligy</a> http://lasix-buy-online.net/

http://flagyl-online-buy.net/ - Metronidazole 500 Mg <a href="http://priligy-cheapest-price-buy.org/">Priligy Dapoxetine</a> http://lasix-buy-online.net/

Configuracion de Switch Chip

Switch

A partir de esta seccion, vamos a comenzar a definir que puertos van a ser utilizados como WAN y el que vamos a reservar para conectarlo a SequreISP.

Para iniciar la configuracion, presionamos sobre el menu de la izquierda en Switch y nos va a desplegar la siguiente ventana con la informacion del chip que tiene instalado el RB:

Rb450g-switch.png

Vamos a estar posicionados en la pestaña Switch, si hacemos doble click sobre el tipo de switch, se nos abre otra ventana en donde vamos a verificar que la opcion Switch All Ports este activada:

Rb450g-switch-switch.png

Port

En esta pestaña vamos a definir que puertos van a ser Tagged y Untagged.

En la ventana siguiente ya se encuentran configurados, por lo que vamos a comenzar a modificarlos para que queden de la siguiente manera:

Rb450g-switch-port.png

Si hacemos doble click en cada uno de los puertos vamos a configurarlos en la opcion de VLAN Mode:

Rb450g-switch-port-eth1.png

La siguiente configuracion no es posible realizarla dentro de la interfaz de Winbox. El VLAN Header lo que vamos a configurar por linea de comandos.

En el menu de la izquierda presionamos sobre New Terminal y ejecutamos los siguientes comandos:

/interface ethernet switch port
set ether1 vlan-header=always-strip
set ether2 vlan-header=always-strip
set ether3 vlan-header=always-strip
set ether4 vlan-header=always-strip
set ether5 vlan-header=add-if-missing
Importante
La interfaz por donde estamos conectado tiene que quedar con el VLAN Mode en fallback, ya que si esto se modifica vamos a perder conexion con el RB y tendriamos que resetearlo completamente.


Configuracion por linea de comandos
/interface ethernet switch port
set ether1 vlan-mode=secure vlan-header=always-strip
set ether2 vlan-mode=secure vlan-header=always-strip
set ether3 vlan-mode=secure vlan-header=always-strip
set ether4 vlan-mode=secure vlan-header=always-strip
set ether5 vlan-mode=fallback vlan-header=add-if-missing


Vlan

Aqui vamos a configurar los VLAN ID que van a ser identificados en la interfaz de SequreISP.

En la ventana siguiente ya se encuentran configurados, por lo que vamos a comenzar a modificarlos para que queden de la siguiente manera:

Rb450g-switch-vlan.png

Primero vamos asignar en la ether5 los VLAN ID y esto lo vamos a repetir con cada uno de los ID.

Rb450g-switch-vlan-eth5.png

y luego vamos a crear un VLAN ID 0 en donde vamos agregar las interfaces que van a ir conectados los Proveedores.

Rb450g-switch-vlan-ethall.png


Configuracion por linea de comandos
/interface ethernet switch vlan
add ports=ether5 vlan-id=10 switch=switch1
add ports=ether5 vlan-id=20 switch=switch1
add ports=ether5 vlan-id=30 switch=switch1
add ports=ether1,ether2,ether3,ether4 vlan-id=0 switch=switch1

Rule

En esta pestaña final vamos a indicarle a donde tienen que dirigirse los VLAN ID, cuales son las interfaces asociadas y por donde tienen que regresar.

En la ventana siguiente ya se encuentran configurados, por lo que vamos a comenzar a modificarlos para que queden de la siguiente manera:

Rb450g-switch-rule.png

Al presionar en el simbolo [+] vamos a configurar las ether en donde se identifican los paquetes not present (Untagged) y hacia que puerto tienen que dirigirse y agregar el VLAN ID a la interfaz destino .

Esto lo tenemos que repetir con las interfaces ether1, ether2, ether3, ether4, especificar el VLAN Header: not present y en New VLAN ID configurar 10, 20, 30, 40. Aca desplegamos solo un ejemplo con la ether5.

Rb450g-switch-rule-eth1-match.png Rb450g-switch-rule-eth1-action.png

Ahora vamos a indicarles el regreso desde la interfaz ether5, que VLAN ID contiene y por donde tiene que salir.

Esto lo tenemos que repetir con los VLAN ID 10, 20, 30, 40 y tambien en New Dst. Ports: especificar las ether1, ether2, ether3, ether4. Aca desplegamos solo un ejemplo con la ether1.

Rb450g-switch-rule-eth5-match.png Rb450g-switch-rule-eth5-action.png


Configuracion por linea de comandos
/interface ethernet switch rule
add new-dst-ports=ether5 new-vlan-id=10 ports=ether1 switch=switch1 vlan-header=not-present
add new-dst-ports=ether5 new-vlan-id=20 ports=ether2 switch=switch1 vlan-header=not-present
add new-dst-ports=ether5 new-vlan-id=30 ports=ether3 switch=switch1 vlan-header=not-present
add new-dst-ports=ether5 new-vlan-id=40 ports=ether4 switch=switch1 vlan-header=not-present
add new-dst-ports=ether1 ports=ether5 switch=switch1 vlan-header=present vlan-id=10
add new-dst-ports=ether2 ports=ether5 switch=switch1 vlan-header=present vlan-id=20
add new-dst-ports=ether3 ports=ether5 switch=switch1 vlan-header=present vlan-id=30
add new-dst-ports=ether4 ports=ether5 switch=switch1 vlan-header=present vlan-id=40